Community
OpenEnergyMonitor

Community

EmonEVSE incorrect Eco amperage?

Hi,
My EmonEVSE has been working well for a year in Eco mode, but in the last couple of days, it is sending about 1kW too much power to the car.

Looking at my chargepoint’s OpenEVSE webpages, I see the MQTT setup still being as I expect, and my MQTT topic is being sent from my emonPi without problems.

In the OpenEVSE>ChargeMode section I am switched to Eco and as I write the ChargeMode values read:
Solar: 621W 2s | Charge Rate: 6A.
Solar: 800W 3s | Charge Rate: 7A.
Solar: 1146W 2s | Charge Rate: 10A
Solar: 2161W 1s | Charge Rate: 19A

…and these solar values do correspond with the MQTT feed from the emonPi

I would expect these amperages to be about 4A smaller, and historically they have been.

I have tried repowering the emonPi and the emonEVSE, and changing and resaving the MQTT settings in OpenEVSE, with no improvement.

Powered by OpenEVSE and OpenEnergyMonitor
Version: V2.7.8

Can someone suggest a next step please.
Many thanks, David.

For the time being, I’m trying a fudged fix by putting a calibration offset in the emonPi MQTT, subtracting 1,000 watts before sending the topic to the emonEVSE.
When charging in Eco mode this is effective in holding my grid CT at around 0 watts (where recently it has been around 1,000w).
But this has the effect of making the emonEVSE readings look wrong, and may have introduced who knows whatever instabilities.

Cheers, David.

Been looking at this and yes there does look to be an issue with the conversion between watts and amps I will do some investigation.

Thanks Jeremy,
I wonder if its simply that the software in my unit has become corrupted. The unit has been working fine for a year, but since the last few days it’s all squiffy.
I noticed the other day that the elapsed time during the current charge session was about an hour too large, but yesterday the elapsed time was stuck at zero throughout the session.
And my attempt to offset my “SurplusToEVSE” MQTT topic by subtracting 1000 watts doesn’t seem to work. Here’s my graph from yesterday. Notice how the EVSE is very nearly working - it resonds to the increase in domestic loads at 10am, but fails to track the available surplus. I expect the EVSE to track the solar curve, but below the solar by the amount of the blue domestic loads - My MQTT topic to the EVSE is “solar minus domestic minus 100”…


Here’s another graph from last year that shows things working well…

So, because this looks like a recent “crash” I’m wondering if I should just reload the software in the emonEVSE and see if that fixes things. Are instructions for doing that posted on the site somewhere?
Many thanks, David.

I will double check again tonight but I was able to reproduce locally, so don’t think it is specifically your setup.

1 Like

Hi Jeremy. I may have found a fix today :slight_smile:
Start position: after power off reset of EVSE and emonPi, symptoms were same as reported earlier.
In EVSE browser interface Hardware panel, reset Firmware - no improvement.
In EVSE browser interface Hardware panel, reset WiFi - all comes good. EVSE charge amperage correctly matches the available wattage broadcast on MQTT.

My rig is still playing up, but we have learned to live with each other :wink:
The current behaviour is:-

  1. Open EVSE control panel in a browser and notice whether the MQTT received value is fresh, or stalled many hours stale. I don’t have a stale screen grab, so here is a fresh one. 3 seconds…EVSE_MQTT_received
  2. If (more often the case after an overnight) the value is very stale (eg 17 hours), log in to the local emonPi feeds page that is publishing the MQTT and edit it… …any small edit will do - just enough to refresh the status. I generally change my 100watt “cushion” by 1watt.
  3. Coming back to the EVSE control panel, notice that the MQTT is now updating normally in real time.

So, this is the position. All is workable, but I’m wondering what to change to make the MQTT connection more permanent so I don’t have to go through this reset each time I want to use the EVSE.

Perhaps an update of the emonPi? I’m currently running low-write 9.7.9 | 2017.01.05

Any advice gratefully received. Cheers, David.

The version could be an issue, that is pretty old.

If you do decide to update, the route to take is to get a new card, flash a new image and import the data via the USB method (all in the docs). This preserves the old card as a roll back option.

We are currently working on a significant update to the OpenEVSE solar PV divert. This update will be available as an OTA update for existing OpenEVSE’s