Community
OpenEnergyMonitor

Community

Emoncms update issues

Tags: #<Tag:0x00007f56c1ee6a28>

Hello,

I have the version 9 of the emoncms running on my RaspberryPi but decided to update it to the latest version today. Update was successful but I no longer see the graph on the menu and I also can’t seem to see the feed lists according to node. The dashboard option is also no longer on the menu. I had to bookmark the URL in the previous version before I can access the dashboard.

What should I be looking at?

I suspect you do not have all the optional modules installed.

TBH, the best way would be to start from scratch with a new card (they do wear out) and the EmonSD image. That will have everything you need plus it will be Buster based.

There are a number of threads that will help you. All your data can be migrated.

Thanks for your response, I had the modules running when I was on version 9. The car is relatively new (just a few months old) and it’s serving me properly. I am able to access my dashboard via a saved link just that it’s not showing on the menu items and also the graph. I will prefer to fix this instead of starting over as the process of physically accessing my RaspberryPi is complicated. So how can I reinstall the modules without losing my data?

Hello @ojeysky did you update via the Admin interface or by running git pull on the main emoncms repository?

Exactly, I did the pull in the emoncms directory and after completing the installation via the admin page, I went back to do I pull and it indicated that I have the latest

Ok, the update mechanism via the admin UI should update all the sub modules like graph and dashboard but it sounds like this did not happen in your case.

You could try running the updater manually via command line

/home/pi/emonpi/service-runner-update.sh

Thanks a lot for the follow-up, that particular command did not run on my setup. Meanwhile everything seem to be fine now[1] except the dashboard. My former dashboard is not listed on the list of dashboards when i clicked on the dashboard menu item, i also cannot create a new dashboard. I have attached screenshots as well.

Regards

  1. I had to run git pull within each of the modules to have all the modules setup

What did it return when you tried to run:

/home/pi/emonpi/service-runner-update.sh

In the dashboard module could you try the following and copy the printed result here:

cd /var/www/emoncms/Modules/dashboard
git status
git checkout stable
git pull origin stable

Here is the response for each command with image attached, the issue was resolved after running those commands. Thanks a lot for the support:

[email protected]:~ $ /home/pi/emonpi/service-runner-update.sh
-bash: /home/pi/emonpi/service-runner-update.sh: No such file or directory
[email protected]:~ $ cd /var/www/emoncms/Modules/dashboard/
[email protected]:/var/www/emoncms/Modules/dashboard $ git status
On branch master
Your branch is up-to-date with ‘origin/master’.
nothing to commit, working tree clean
[email protected]:/var/www/emoncms/Modules/dashboard $ git checkout stable
Branch stable set up to track remote branch stable from origin.
Switched to a new branch ‘stable’
[email protected]:/var/www/emoncms/Modules/dashboard $ git pull origin stable
From https://github.com/emoncms/dashboard

1 Like

Good to hear, out of interest, are you using a standard image or is this a custom build? do you have emonpi repository in /home/pi?

Its a custom build hence i don’t have emonpi /home/pi
That said, i want to be able to access my dashboard which is currently behind a LAN on the internet. I have tried to setup a sync to my account on emoncms.org using emonhub but below is the error message i got:

Have you considered using dataplicity for remote access direct to your pi? They have one free account per user and you don’t have to setup everything twice https://guide.openenergymonitor.org/setup/remote-access/

How are you currently posting data into your local emoncms? is it via our rfm69pi adapter board? or are you using a custom script by chance?

Thanks for letting me know about dataplicity, will look into it.

As to your question, yes i am using a custom script, specifically the solpiplog: https://github.com/njfaria/SolPipLog

1 Like

ok great i think that might explain the emonhub error… i’m not familiar with solpiplog to support i’m afraid, but the readme suggests that it can send to a local emoncms or emoncms.org. I think you might find dataplicity a good solution though

Duplicity addresses my need. However i am getting the following error when i tried accessing my dashboard. I have already made the dashboard public

Not configured
or
Authentication not valid

im not quite following that error, any chance of a screenshot?

Here is the screenshot

1 Like

ah ok, you need to make the underlying feeds public as well

Hmm…can’t seem to find where to make feeds public on my feeds page

put a tick in the relevant tick box and then click on the pecil icon, then a tick in the make feed public box