Emoncms server feed page

I have a emoncms server install in ubuntu 16.04. Server was working fine. I sent some data through python. Due to some mistake in the python code data syntax was not correct. And feed page stopped updating. In administration page I deleted all feeds and inputs. Still feed page is not updating. Server accepts data but does not let me see / add any feed. Sometimes I also get data syntax error but receive the data. I am using firefox and I see a moving circle on the screen when I visit the feed page. I also reinstalled server without removing the old installation but the situation is still same. How can I fix the feed page issue so that it let me add and see the feeds?

Oh dear! there have been a few instances like this, mainly on the inputs page but also the feeds page. Have you tried to clear the browser cache (you can use CTRL-F5 in many browsers).

are you running the very latest emoncms? See the “Input list doesn’t load” for the latest attempt to fix this.

It could be that the “invalid data” you posted in error is still lurking somewhere causing an issue, if clearing the cache doesn’t work you could also try flushing redis too.

Thanks Paul. I am using most recent version of emoncms server. I ran ‘sudo redis-cli flushall’ and cleared browser cache but that did not make any difference. I also install and tried Chrome but that did not make any difference. As I wrote before, using terminal I reentered all server install commands but situation is still same.

My server is hanged up at http://localhost/emoncms/feed/list page. When I go to localhost/emoncms/input/post.json?node=1&json={power1:100,power2:200,power3:300} I get ‘SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data’ error. localhost/emoncms/input/process/get.json?inputid=1 response is false. /var/log/emoncms.log has nothing.

Any solution for me please? Thanks

An update.

I fixed my issue by:

mysql>DROP DATABASE emoncms;
mysql>drop user ‘emoncms’@‘localhost’;
mysql>flush privileges;

restart computer

mysql -u root -p
mysql> GRANT ALL ON emoncms.* TO ‘emoncms’@‘localhost’;
mysql> flush privileges;
mysql> exit

Now emoncms server is working fine. Thanks

Glad you got it sorted and thanks for letting us know, someone else may find this useful too.