Community
OpenEnergyMonitor

Community

Emoncms Recovery after Power Cut

HI

Following a power cut this weekend I have lost my Raspberry Pi emoncms data. Courrupted SD Card.

I have put a clean install of Emoncms 10.2.0 on a new cardand it is running OK I cannot recover the data form the old card using the back up function. It says USB not found. Any ideas. Can I manualy copy the old files across and which are they.

Also on the new install the SD expasion command doesn’t work. Again any ideas.

Any help appreciated.

Do you mean using the usb_import script?

@TrystanLea posted this. Backup module usb-import.sh script (beta) about recovering SD Cards.

At a minimum I recommend a filtered/spike protected plug/extension lead for RPis. They are a little prone to this it seems.

Thanks Brian I used the backup utility on emoncms. I downloaded a clean emonSD-17Oct19 version. I tried an fsck which cleaned up a lot of errors but I could not get the old disk to boot. I did notice though the corrupted SD card is lableled sdc1, sdc2, and sdc3.

Hi Brian I used the post and it worked a treat. Thank you. I had to delet Mass-storage in the script but back on track. Many thanks to other contributors.

I am still a little unclear whether the new sd card has been expanded any ideas.

$ lsblk
NAME        MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
mmcblk0     179:0    0 14.5G  0 disk
├─mmcblk0p1 179:1    0  256M  0 part /boot
├─mmcblk0p2 179:2    0    4G  0 part /
└─mmcblk0p3 179:3    0 10.1G  0 part /var/opt/emoncms

If there is a difference between the disk size and the total of the partitions, then no, it hasn’t expanded.

Brian

Thanks disk looks good.

Thanks again for your help.

Regards

Richard

1 Like