EmonCMS input error after updating from 11.0.6 to 11.0.7

I have an EmonPI running emonSD-24Jul20. I have two IotaWatt units pushing data to the emonpi, and this has worked for years now. This morning I upgraded the EmonPi from 11.0.6 to .7, and one of the IotaWatts works as before, while the other suddenly pushes data to a new set of inputs:

Embarrassingly enough, my newest EmonPI backup is from early January this year. The IotaWatt data can be retrieved for the period in between, but it will take time, and I have never used a backup before. If I knew this could solve the problem, I would do it.

The other way would be to reconfigure the emonpi and create 18 new feeds. This is a lot of work, not at least because it will sort of mess up my dataflow downstream in a quite spectacular way with a lot of reconfiguration needed. It will also result in losing continuity in the emonpi feeds.

Can anyone point to the best solution here? Thanks!

Hello @OlavKristiansen that’s strange there’s no significant change other than documentation between 11.0.6 and 11.0.7 so I cant see what would have caused this. Perhaps a glitch during the upgrade… Have you tried deleting the new inputs, they might reattach to the old ones?

No, I did not dare deleting anything. I can try and see. The reason could maybe be related to unfortunate simultaneously reboot of the emonpi and the iotawatt?

Have you checked all the services are running? How does the data come in? Via MQTT?

Anything in the logs…

Might just be duplicate Feeds Inputs (at the bottom) - delete the new feeds inputs (the ones without an input process).

Not MQTT, but IotaWatt. They push data to emonpi using an emonpi write key.
I’ll check the logs!
Not duplicate feeds. If you look at the image above you see the inputs. All the original inputs have n/a, while I suddenly got a new set of 18 live inputs.

IotaWatt is a Product, MQTT is a transport protocol. If it uses the API Key then it will be using the HTTP API.


As I said above,

I should have said Inputs not Feeds

Ok, thanks for the explanation.

Ah, thanks for the edit, the “feed” instead of “input” really confused me… I will try this tonight.

1 Like

Sorry about that :frowning:

No worries, grateful for the help :+1: :+1:

Brilliant :smiley: as simple as that - thanks!!

It looks like there is an issue on a reboot that is causing this to happen @TrystanLea.

I also have an Iottawatt and 8 feeds, and my Radial buttons are all broken

This broke a few days ago, figured I was out of credits, so renewed, but show full credits again and still broken.

Looks okay to me. Try clearing your browser cache?

Do you have any duplicate inputs? If so delete them.

Almost certainly a browser cache issue, I’d suggest.