Emoncms feeds not updating


I am currently trying to get the My Heatpump running on emoncms and ive tried to sync them but there not updating.

Locally they are all working and updating.

But on my emoncms.org account it looks like this.

Any idea where to start with this?





Could anyone help me with this?

Been like a year @TrystanLea and @borpin and @glyn.hudson .

Ive recently upgrate to new firmware. and still not updating ?

At a loss.



Trystan must have missed this.

First question, where is the data coming from, and how is it getting into your local emonCMS?

If it’s coming in via emonHub, then it’s possible to send to a remote emonCMS via emonHub. If the data is coming in via your LAN, then this route isn’t open to you.

Hi Robert

I have an emontxv3 transmitting data via RF and my base an the emonbase rpi3b.

All my feeds are updating fine locally.

just not remotely. Ive tried renewing my API key but that didnt work either. I am also using the read/write API key in my emonhub config.

any other ideas?

Have you tried sending some data manually via your web browser? The API help gives several formats (include the same APIKey that your local Pi is sending (you did get the APIKey from emonCMS.org, didn’t you, and you’re NOT using the local one - because they are different!).

I dont know how to send data manually.

Yes I updated the APIkey on the cms server and copied to locally.

Log in to the remote emoncms.org, and look at the API Help on the Inputs page.

Copy this into your web browser’s address bar, making sure you add the APIkey from your Input API Help:

(This is not your - nor my - APIKey.)
Then look at the Inputs page itself and see if the values have appeared.


Tried this and nothing updated.

This means you are almost certainly not sending the correct API Key.

Let’s be clear: your local emonCMS on your Raspberry Pi, which is your emonBase, is totally separate from emoncms.org
Though both offer much the same options and features, there are differences, generally, the on-line public emoncms.org lags features and facilities that are first introduced in the locally hosted version.
The APIKey is in effect a password, which allows you to write data into emonCMS. Because the two emonCMSs are different, the two APIKeys are different.

To write data to your emoncms.org, you must use the read/write API key that you see on the Inputs API Help page at emoncms.org. Did you substitute this for the false API Key in my example?

What response did you see on your browser screen? When the command has been accepted, you should see a simple “ok” in the top left corner, nothing more. You need to return to the Inputs page to see the data itself.

Hi Robert,

Thanks for the reply.

So my api key in my emonhub config file is the same as the read/write on emoncms.org.

In the broser I got a message that just said ‘ok’.

But not change on the emoncms.org.

very strange.

Are you quite sure you’re looking at what you think you’re looking at? You looked at the Inputs page - and refreshed your cache with [ctrl]+[f5] ?

If you’d like send me a PM with your emoncms.org username & password, I can try sending the same command from here.

Hi. Not tried refreshing the cache.

I have pm you my username and pw.

Hopefully figure it out. Its got me this one.

I’ve replied to your PM with the evidence. You should see the ‘emontx’ entry on the Inputs page.

I can’t understand why you saw “ok” but no update, other than it was a cache problem. That might not be the whole problem, but it’s narrowed it down and I’m happy that emoncms.org is working correctly.

You do have a subscription for the feeds on emoncms.org, don’t you (it is a paid for service)?

I tried to help - some of the data from the local emonCMS - that which is appearing in emonHub - is being forwarded correctly to emoncms.org, but it appears that there’s another mechanism at work that I have no knowledge of, because in the emoncms.org My Heatpump app, there are sources listed that aren’t mentioned elsewhere as far as I could see, and it’s (some of) those that aren’t updating.

Yes I have a paid subscription. :slight_smile:

Im at a loss now.

I really have no idea why I cannot publish new data. Original data is fine- no probs.

I think for now I will ping new data via node red using the emoncms node.

@TrystanLea @glyn.hudson @Gwil

Hello @gjones84 what is the feed interval of your local data? is it 10s data? You can hover your mouse over the feed name to check