Community
OpenEnergyMonitor

Community

EmonBase Data collection not starting automatically after reboot


(Sidicas) #1

I have an EmonBase and yesterday I reimaged the SD card with emonSD-30Oct18 (Stable). This causes the Pi to lock up on boot. I guess the hardware (maybe this is a Pi2? I don’t know) is not supported.

So I had to reimage it with ( emonSD-26Oct17).
This works, boots, and I’m able to complete setup. I was immediately able to see my data being received. I did an Adminstration -> Update and it completed without erorrs.

However, every time I reboot the Pi, it does not collect any data.

In Administration -> Server information
I see mosquitto and emoncms_mqtt as failed/not running.

The only thing logged is:
2019-02-20 16:47:51.478|ERROR|feedwriter.php|Starting feedwriter script

Then nothing logged after that.

After quite a bit of fiddling around I was able to get it working again by running the following commands:

systemctl start mosquitto.service
systemctl start emoncms_mqtt

I need to do this every boot or it does not collect any data.
Any suggestions on how to automate this?
I have tried enabling the services but they are already enabled.

I did not run the EmonPi update, I only ran the EmonBase update. This is because I have an EmonBase (not EmonPi). So I’m not going to run that unless I need to or I missed something in the documentation.=


(Sidicas) #2

These are also dead/not running.
I don’t think they matter though since I think they were also dead after the update where I was still getting data through.

|service-runner|Inactive Dead

||emonPiLCD|Active Exited|


(Brian Orpin) #3

As per the readme (basically anything that is not a Pi 3)

To use this image on Pi2 remove the following lines from /boot/config.txt :

arm_freq=1200
arm_freq_min=600

Please try this solution as the old version is not easily supported now - much has changed and it is a Jessie base image rather than Stretch.