EmonBase - Backup does not run any more

Hi, I’ve been running an Emon system for a little over a year with no major problems. The system consists of an EmonTx, three EmonTH and an EmonBase, the latter is on a UPS.

The only funny is there are now five non existent nodes shown in the inputs and feed screens, I think the last one, labelled ‘3phase’ appeared after the EmonTx suffered a power glitch.

At the end of every month I run a backup and update the firmware. This month the backup does not run, The log window shows last months backup as it completed, I click the backup button and all it does is blink and show last months back again. It usually runs through the backup process, which takes several minutes, then I can refresh and download it. Any suggestions please ??

If some-one can tell me how, I can post the system details.


I had exactly the same on my emonpi 9.8.31.
Saw nothing in the log.
Just did a reboot of the rpi through ssh.
After that backup worked fine again.

Thanks, I’ve tried re-booting and nothing changes, just blinks the log window and shows last months backup log again when I click the backup button.

Anything in the log window when you click on the backup button?

Hi, thanks for your reply. I assume by the log window you mean the window below the ‘create backup’ button ? This shows last months (5 July) successfully completed backup. When I click the backup button it just clears briefly, then shows the same. It used to clear and show the progress of the current backup, which used to take several minutes to complete.

I have the same issue with an emonPi (Version: low-write 9.8.30 | 2018.05.08).

Every time I press “Create backup” the log window says “Backup flag set”, then it disappears and I get nothing else.