Emon Tx V4 and DS18B20 via RJ45

Do I have to do anything special to get Emon Tx V4 to read temperature from the RJ45 socket?

I have replaced my Emon Pi with an Emon Tx (moved the Pi elsewhere for various reasons). I had a set of 3 DS18B20 sensors connected via the RJ45 to the Emon Pi, via one of your RJ45 to Terminal Block Breakout boards.
Having plugged it into the Emon Tx I’m not getting any readings on the T1, T2 or T3 data outputs (I’m getting CT clamp data and so on, so I’ve got connectivity).

Do I need to do anything to make this work?


Hello @tomq42 nothing special, the sensors are detected at startup, so if they are not coming through you may need to power cycle the emonTx4.

Yes, I’ve tried that (should have said). I’m fairly sure originally I plugged the RJ45 in before turning it on. I know from the EmonPi that it only detected them if they were present at startup.
I’ll try wiring one of them directly and see if that helps, hopefully I have enough cable. The EmonTX only came with 1 connector for those plugs though, can I get more?


Ok great, what length cable do you have on the temperature sensors?

Two are just standard, but I don’t know whether I have enough slack to get round to the inputs on the Emon TX. One I have extended (it is an outdoor temperature sensor) so it’s maybe 4 meters. Currently they are wired into the RJ45 breakout board and I have a short ethernet cable connecting that to the Emon Tx. I will have to see how much slack I have.

Great, are they call connected up with GND, DATA and POWER (3.3V)?

They were all working before, but I will check all the connections when I have a bit of time.

Can you plug something into the USB to view the serial data?

Presumably communicating via RF?

So I’ve just tried connecting one of the sensors directly and I’m still getting nothing. I tried a couple of the sensors in a couple of the sockets and it’s not giving me anything. The wires seem to be well connected into the terminal blocks as far as I can see. I power cycled the EmonTx each time, but it’s giving me 0. The wires are connected to the terminal block according to your picture (black, white, red), and the plug seems to be fully in the socket.

As above

Hello @tomq42 I wonder if you could open the emonTx4 case and take a look at these solder bridges, the links labelled TMP for temperature should all be linked, Im wondering if we’ve missed this on your board? but then I guess the RJ45 didn’t work either? so its probably not that.

Another one for the docs?

Will the RJ socket just work?

Yes probably best check the serial first as @borpin suggested and then if we cant get to the bottom of it we could send you another board to test?

This is in the docs here: https://docs.openenergymonitor.org/emontx4/other_sensors.html#temperature-sensing

1 Like

I’ve literally no idea what I would do to do that.
Right now I don’t have a USB to USB-C cable anyway, so right now, no.

I can see from the configuration page there is:

t0 <y>** turn temperature measurement on or off: y = 0 for OFF, y = 1 for ON

I will get hold of a relevant USB cable and explore the configuration settings. My guess is that temperature measurement isn’t turned on.

I tried to see if I could see the bridges through the side panel, but I couldn’t, so I will dismantle it at some point to check. Screwdriver is in the garage and it was too cold this morning to go outside and get it :slight_smile:

1 Like

It is very simple. Plug the USB cable in the TX4 (correct way up) and into your computer, then use the web page to view the data Configuration — OpenEnergyMonitor 0.0.1 documentation

Worth the investment in a USB A-C cable

It’s defeated me so far.
I have a USB-C cable now. Plug it in to the computer and I get a “CP2102 to UART bridge controller installing” type message (this is Windows). So the computer is registering it at some level (put the USB-C socket the wrong way up and you don’t get that).
However, if I open the “Serial Monitor” page an press “connect” I get a dialog with “openenergymonitor wants to connect to a serial port”, but it then says “no compatible devices found”.

It’s unclear whether I am supposed to have purely the USB-C cable plugged in to the EmonTX, or whether I need anything else plugged in (I’m unclear which of the two cables from the emonVS is the power supply and which is the voltage monitor). I’ve tried it both ways.

I have tried two different laptops and get the same both times.

Chrome privacy settings are set to “allow pages to ask for connections to USB devices/Serial ports”.

TMP solder bridges are present as per the picture.

Are you seeing the regular flash form the EmonTX when the USB is plugged in?

Windows Device manager:

Chrome popup window:

This look like there is an error (the yellow triangle)