Community
OpenEnergyMonitor

Community

Emon Base pi Crashed

Tags: #<Tag:0x00007f6e08f0d0c0>

Hi, After several years of successful monitoring of my system started back in 2016 I think, I increasingly encountered a problem with the pi dropping off my network (wired) necessitating a reboot. This occurs at more frequent intervals up to twice or three times per week. I have updated the software on both the emon pi and the emontx. I stumbled upon a little script that pings the router at regular intervals using crontab and if it gets no response it restarts the pi. Then hopefully the connection to the network is restored. I use the mqtt server to switch loads when solar exceeds normal consumption. I trialled the script on a normal pi and it was working successfully. I now attempted to recreate the script on the Emon Pi. So far so good, until I ran the script and the ping command was called. An error was flagged up and it seemed that this command was disabled. I tried to find a way to enable it and looked at the raspi-config. Upon exiting this module I was prompted to restart. Well… now not a sign on the network. Removed Emon Pi and plugged in monitor, mouse and keyboard and powered up again. I get some kind of startup script, but then it carries on endlessly. I attach a picture of the scrolling messages, unfortunately I cannot take a picture of the start of the output, its just too quick. Can anyone help please. I have tried to interupt the output but with no sucess I think you can just make out the text

Sounds like the SD card has failed. You have got a backup of the data, right?

Only solution is a new SD card with a new image (or buy a ready to go one from the shop).

Hi Brian, thanks for that, you wouldnt believe this but I had “backup emon pi data” in my tasklist for tomorrow!

Yes I really would believe it!

Chances are the data are toast.

I tend to use it as a real time tool to manage my system and loads, but not so much looking back on historical data, although this is always interesting. Whilst Ive your ear, do you know why “ping” wouldnt work for me?

You get all sorts of oddities as the cards fail.

1 Like

Hello @Patd37 it might be worth trying to restore the SD card using the fsck tool, see the section of the guide here: https://guide.openenergymonitor.org/setup/import/#restore-using-a-usb-sd-card-reader

Hi @TrystanLea thanks for the heads up on fixing and restoring. It actually took me longer to find a micro sd to USB device that worked. my old card reader, which took a standard sd card with adaptor dropped the voltage too much but eventually found a suitable one on the internet and that worked fine. thanks again

1 Like