Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Eco / PV Divert not working after upgrade to v4

As above - currently sitting with 10A+ available but not charging.

Used to work; recently upgraded to 7.1.3/4.0.1 and first time I’ve tried since.

MQTT feed is working / changing.

Has been charging my wife’s Zoe and my MG5 on overnight timed charge OK.

Don’t appear to be able to force it to charge in Normal mode either.

Interesting, could you post your solar PV divert settings? e.g here are the default settings

Could you try disabling the charging timer? Solar PV divert should be able to work when the charging timer is enabled but it would be good to eliminate this.

Oh dear, what happens when you try to force it to charge in Normal mode?

Settings are as below. Has worked fine before the update to V4. Weather is pants today so won’t be able to get the divert running with the timer disabled.

I’ve managed to get the manual charging working if I cancel the timer; I don’t recall having to do that before with v3 but maybe I’m mistaken.

To update, if I switch to Eco when the normal times are showing for my overnight charge it will sit in ‘Waiting for Solar’ for ever with the status showing -‘Waiting - EV connected’

As soon as I hit the cancel button below the times (which clear the times out), it moves to ‘EV Connected’ and as soon as the solar is sufficient, moves to ‘Charging’.

So I guess the Eco setting isn’t overriding the set charge times.

Also something weird going on - it then decided to charge at 32A even on Eco.

Thanks for the observation. I agree it would be optimal for EcoMode to be able to override the charging timer while there is excess PV power then ‘top-up’ the EV at full power overnight during the charging timer period. I will open and issue and get this functionality restored.

That’s strange, there must be something going on with the values coming from your emonTx. It’s important that the power used by the EVSE is included in the Grid Import/Export, the CT should be clipped on the main incomer power feed as it enters your property before the EVSE or any other loads The figures for Grid Import/Export should be negative when exporting power.

Are you logging data to emoncms.org? In order to try and debug further I’ll need to see a graph of solar PV generation, grid import / export and EV power. If you’re already logging data to emoncms.org with your permission I could take a look at your data?

I think all my CTs are OK. I’m not logging to emoncms.org.

Is there an easy way of cloning all my feeds to there?

Same thing happened again today; happily charging on solar excess and then suddenly decides to charge at the full monty of 32A.

The four screenshots below are the feeds for the house (Highbanks - which is the one used by the OpenEVSE to determine import/export) and the other is the clamp on the output to the charging unit.

I switched to Eco at noon. 47 minutes later it ramps it up to 32A and then my battery system (which was happily full charged by then) kicks in to top up the solar output (which was running at about 5.4kW around that time).

I came back in from the garden and stopped it once noticed.

Definitely something weird going on and I didn’t see it with the v3 software.




Thought I’d give it one m ore go as the 20kWh of batteries were charged and the thermal stores both > 90 so no PV divert to them either.

It worked OK for a few minutes and then ramped up to 32A. Took three screenshots which show the charger charging (wrongly!), the excess config values/settings (under Services) and then some of my feeds which show the PV knocking out 4.5kW, the Eddi taking nothing, the charger taking 7.3kW, the battery system throwing out 3kW and the house importing 883W.

I’ll be leaving Eco off until this gets fixed and stay on the timed overnight charge ; shame, as I try not to export but sending 3.3kW to the grid right now …



I think I can see the issue, the Grid +I/-E feed should be the actual grid import/export and should include the EVSE power. If you are sure the Grid +I/-E includes the EVSE power than to deug further I will need to take a look at the data in more depth. Would you mind giving me access to your emonPi? If you are happy with this, I will PM you with a SSH command to enable this. You will need to connect to the emonPi via SSH.

The CT is definitely on the tails, albeit inside the CU so is the house import/export. The power taken by the EVSE is via a 40A MCB and then the RCD thing I bought from you. There is another CT on that which logs the charge taken by the EVSE unit.

I’m now logging to emoncms.org as greentangerine and have made the feeds public but happy for you to access the emonpi directly - I think I already have Dataplicity on there.

Ok, that sounds good.

Thanks, I’ve just taken a look.

I can see that one the EVSE config you have set the Grid I/E MQTT topic to emon/emontx3cm16/P3, looking at your emoncms.org inputs this input (Node 16, Key 3) is labelled as eddie.

I think the correct feed for your Grid I/E is Node 16, Key 5 which is labelled as house house. I think you should change eddie label to grid and change the OpenEVSE Solar PV divert MQTT topic to emon/emontx3cm16/P5

With so much battery storage, it’s awesome how little you import from the grid!

It’s rather confusing that your OpenEVSE power feed and Eddie power feed are negative. Personally, I would either flip the CT or multiply by -1 to invert these feeds. But maybe you prefer then this way!

Not sure that’s it.

The EVSE is getting the MQTT data from the emonpi and for some reason the emontx inputs have a different name to those seen on emoncms.org i.e on emoncms.org feed 1 matches ‘MSG’ on the pi, feed 3 matches ‘P1’ etc. - I’ve put the screenshots below.

So '‘P3’ in the EVSE config is the same as feed 5.


Ah sorry you are correct the Inputs from emontxcm on map emoncms.org are as follows, I had forgotten about MSG and VRMS at the beginning:

MSG         1 
VRMS        2 
P1          3  Eddie
P2          4  Car Charger
P3          5  Home
P4          6  Battery Storage 

I put it on Eco about 14:47 today. Just over an hour later at 15:51 it decided to start charging at 32A.

The data should be on emoncms.org.

Thanks, I’ve just taken a look.

I think I can see the issue, solar PV divert worked correctly between 14:14 - 15:50 when eco mode was enabled ev_divertmode_status=2, then at 15:50 eco mode was disabled ev_divertmode_status=1, as expected when eco mode is disabled the EVSE then charges at maximum power.

The question is why did eco mode get disabled? Assuming you didnt do this via the UI, maybe you something which may have disabled eco mode via MQTT? Eco mode can be changed via MQTT by posting:

Topic: <base-topic>/divertmode/set Value: 1 = Normal or 2 = Eco

or via HTTP by doing a HTTP POST to

http://openevse-XXX/config

with data:

{"charge_mode":"eco"} or {"charge_mode":"normal"}

Have you ever setup have any scripts or triggers which may be switching off eco-mode via either of the methods above? I’ve not heard of this happening before, EcoMode is now persistent between charging sessions and certainly not disable during a charging session.

Hmm, I’m certainly not posting anything via MQTT or HTTP.

The UI was open on my desktop in Chrome and theoretically also open on a Kindle Fire and my phone (also in chrome) but the last two devices were closed and I wasn’t anywhere the keyboard of the desktop.

Would session expiry of something similar do something?

Mmm interesting, so you haven’t got any other services connected to the OpenEVSE via HTTP/MQTT e.g HomeAssistant / Emoncms Demand Shaper etc

There must be something causing EcoMode to disable.When now you open the interface now is Eco Mode is visibly disabled?