Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Eco mode - how good is it?

I’ve only been running my new EmonEVSE for a few days to charge my EV when we are producing enough from the solar panels. But I’m a bit concerned by the usage patterns I’m seeing. There are frequent peaks to the maximum charge of 32A, even though I’m not generating anywhere near enough solar for that. The graph from yesterday looks like this:

More of the same today. I’m getting enough solar to charge the car, but the output looks horrible, and definitely not keeping to the power generated, even though it is in Eco mode.



Any thoughts?

I experienced similar and it transpired the DemandShaper module was also active and the cause - I disabled it and all OK since.

How do you disable that?

Could these setting be changed to make it behave differently? I’ve not touched them from the defaults, as I’m not sure what they do.

This issue I had was that it was taking 32A after seemingly working away happily for a while - there’s no way it should ever do that on Eco unless you’ve got a mini-solar farm in your garden.

The only thing I’ve changed from the default was the min charge time - I halved it.

I haven’t had the problem since ensuring the openevse module in demand shaper was off.

I use EmonCMS online, not on my own local installation. I can’t even see the DemandShaper as an option, so I have no way to control it (that I know of).
But I get similar times when it shoots up to 32A on Eco, when you can clearly see there is nowhere near enough solar power. @TrystanLea, any ideas?

Apologies for this issue, thanks for reporting. This bug has been fixed in the latest version V4.1.0 (currently in beta): Release V4.1.0 | BETA · OpenEVSE/ESP32_WiFi_V4.x · GitHub

I assume I’d be able to upgrade with my current hardware, as it was only installed about a month ago?
image

Yes, no problem. You should use openevse_wifi_v1.bin