there are some users in our german pv forum who have this inverter, as far as i know they run very well. but i cant say if it is communicating well with the diy bms because nobody of them use this bms.
in theory it should run. stuart is also communicating with his inverter via pylontech canbus.

the 12kw deye has a idle consumtion of 90w if this is important for you, this 90w adds to your consumption 24h/7.

do you realy need a 3 phase system?

Hi Dan,

Many thanks for your feedback - much appreciated!
Unfortunately, single phase is not an option regarding the requirements and the existing distribution and cabling.

May I ask where the 90W idle power value comes from? Can’t find this in any Deye specs sheet. Is this from the experience of the German users you mentioned? Surely - wasting energy - especially in idle - is not in anybody’s interest. I think we are all here to achieve the opposite. On the other hand, what does idle in case of an hybrid inverter truly mean? Ideally it is generating power during the day and delivers power through its batteries at night (at least for some hours). So not long in a true idle state.
Without a battery, my current inverter switches down to just a few W when voltages are longer below the min required. When running, it takes a minimum of 105W for itself regarding my own measurements. so 90 W would be at least in a similar ballpark.


so this is then the idle(or on) consumption of your inverter.
i have a sma sunny island single phase, this one has 25w idle (or on) consumption it ads to my consumption on top, i have measured this.

maybe this is diffrent if no battery is connected, idont know. dont have a grid connection, i am offgrid.

I have a solis 5kw hybrid inverter, powered from the battery in off grid only mode it takes 48watts on idle.

Hello @stuart,
The configuration values (The multiplier to calculate the offset between the measured value and displayed value) was not lost. I could get it back from the Web GUI.

As per your comment, I reflashed the module and now it’s working fine. I will see if it happens again and will let you know.

Appreciate your quick response and support.
Thanka a lot.

7 posts were split to a new topic: Update the controller over wifi

Hello everybody,

I`m getting crazy right now.

We´re facing the issue of not being able to manually entering the right value of the Calibration multiplier.

Issue description:
I´ve got a cell that is not willing to accept it`s manually measured voltage.

I´m entering e.g 3.292 Voltage into the Calculater → Press Calcutlate
And than I´m ending up with a value higher than 5,0000 in the Calibration Multiplier.

So logically the BMS is not accepting the value.

Alltogether I can´t change one specifiy value set of the batterie.

Tries without outcome:

Changed the modules 3 times
Changed the modules before and after the issue module
Latest software is installed (todays release!)
Reseted everything several times

I got really badly stuck and please ask for ideas to solve that issue.

MANY MANY MANY!! thanks in advance.


@wired0815 what version of the cell module hardware is it?

To have a value which needs such a out-of-spec calibration value means there is something else wrong.


  1. You are not sharing power cables to the module and battery cell (each module has red/black cable to its own cell)
  2. Check soldering on the ATTINY chip
  3. Check how good the JST cables are these are difficult to properly crimp.
  4. Swap the module with another one - does the problem move with the module?

I suspect you have a higher resistance on one of the power cables to the module, which causes out-of-spec voltage readings.

Hello Stuart,

thank you so much for answering in time.

I´m going to answer top → down

  1. Each cell as it´s own cable to the module. Anyhow we´ll swap cables and double check rigth now
  2. As we already changed 6 times the complete module and nothing went better I think it can´t be the ATTINY chip (as modules are “fresh” so to say
  3. We´re changing the cable. I´ll keep you posted
  4. The problem is not swapping with the module it´s static to “cell” number 10

I´ll write asap I´ve changed the power cable.

Thank you so much for the fast answer!!!

I suspect the JST cable then if you’ve not swapped that out - or cell number 10 has some strange internal resistance/fault.

We already bridged the module to another battery to be sure that it isn´t related to the cell itself.

So it has to be the cable.

A quick change didn´t result in another outcome.

Keep you posted.

Still no changes…

We are at the end now and have absolutely no idea what to do.

Changed modules again
Tried 4 different power cables
Changed batteries…

Attention Update:
The Problem has been shifted:

All modules from 16 → 11 (5 modules are now dismantled from the pack) - number 11 was the one that produced that strange voltage I reported before.

Now as you can see in the screenshot, the “wrong” measurement shifted to cell number “6”.

So I´m more and more convinced that we´re talking about a software issue and not a hardware problem. Or maybe a communication problem. I don´t know…

And another update to it:

If we start to unattach the modules from top number downwards the problem with the wrong displayed voltage is shifting WITH the modules down until we reach number “0” (1st module/cell).

This is for sure a software issue / bug.


When i first built my v4.4 modules i accidentally left off D1 (the voltage reference) AZ432ANTR-E1.

They exhibited the exact same erratic symptoms.

When i say I left off … it was really JLCPCB didn’t have them (nor attiny) - I added the tiny but forgot the voltage ref.

Also make sure you reload your browser - i have on occasions had trouble doing updates to the controller/modules until i reloaded my browser - no error message … just doesn’t work - i haven’t debugged why but believe assume stale cookie.


If it is, it’s the first time it’s been reported in over 5 years! Either way, I’m happy to fix and bugs when found.

I’d be surprised if it were a code issue though. The modules are electrically isolated from each other. They are in effect autonomous, they have their own CPU etc.

All the controller does is ask each module for it’s voltage readings.

In the 2 years I have had this system running, there have been two times that one of the modules has started to go bad, I replaced the D1 and so far. Carlos, from what you describe, it sounds to me like a hardware problem, some component of some modules or of the controller has degraded, it is not frequent, but it can happen
I also recommend that you carefully review the communications (even reviewing the RX TX soldering in each and every one of the modules) and of course the quality of the communication cables

the wait is over , on friday i will receive 57 attiny 1624 purchased directly from Microchip Tecnology . I am looking forward to receive them and test my prototype of 16 modules


Hello, i wanted on this: to solder on my variant 4.5 board directly mounted on cells.
bms v45a
AZ432ANTR have an alternative, i have many LM385-1.2 : LM385-1.2 pdf, LM385-1.2 Description, LM385-1.2 Datasheet, LM385-1.2 view ::: ALLDATASHEET :::

do you want to flash the 10k firmware?

Yes, I want to try the higher speeds
In my previous system for 4.4 modules I can only put speed of 5K