I had the forum translated into Spanish. She had to have written it in English. Apologies

1 Like

I’d be in for a group buy in Australia

1 Like

2 posts were split to a new topic: Modules for sale on

ive been using georges leaf bms on my nissan leaf cells since about the 2nd week he released them they have been rock solid and work perfectly fine and that about 8 months now

Pretty bad when a builder has more runtime experience than the author. You should post a picture of your monster bank. My little 6kw pair will look teeny in compatison.

1 Like

2 posts were split to a new topic: Does the polarity matter for the module serial connections?

the battery monitor on the front has since been upgraded to victron bmv712

Very nice arrangement, very clean. Like the extinguisher ball. So… the handles on the side are so you and a friend can pick power wall up and move it around… Haha

lol no chance of lifting it with 2 people, maybe 2 worlds srongest men might just be able to, it was to move the metal case into the garage which is 3mm steel lined with 12mm cement board so it weighs about 120kg itself plus the 300odd kg of battery in there

Figured it was there to stay…
What do you get for cell-to-cell deviation. My cells still had 60ah (from a wrecked vehicle) and I never saw more than 10mv spread.

about 13mv and there is 2 cars worth there but they both 2011 models gen1 cells

Hi , nice building
Now i know this board fit to GEN1 cell :slight_smile:

But with such cell in // the balancing working nice? not to low?
how many cells can we stack? I see 25 on your’s, how much can the lower one withstand?

the components are the same between v4.21 and leaf 4.00?

1 Like


ISSUE after flashing existing and new cell modules and controller with newest firmware… the Contoller cant communicate with any of the cell modules.

  • When flashing the modules and controller it uploads and reads/verifies just fine.(using PlatformIO(which i prefer) - AVRDUDE keeps giving errors)

  • But i noticed that new modules and modules that were previously flashed, the leds act(flash) differently. After flashing the new modules the red led blinks quickly and the green led blinks every 2sec on the modules. But When flashing Existing modules which were previously running older firmware it writes and reads/verifies just fine with no errors but the green led flashes quickly and the red led is flashing super fast and almost appears to be steady because its flashing so fast…

Regardless, neither modules will communicate with the controller… Ive tried reuploading bootloader and eeprom and both write and read/verifies fine but still same issue.


Ok, you can always go back to the older version, however try the set fuses option before programming.

It sounds like the clock speed is running strange.

Are you using the code from the master branch?

What I have done yesterday (one option for each try)

-B16 option on/off

-disconnect USBASP from USB Port and connect after pressing upload right before flashing starts.

  • first flash old fw then new one

  • combine

there is a bom with the gerber files its a hybrid of 4.21 and v4

i couldnt see a reason in why you woud want to stack more than 26 high, they get very top heavy and unstable if you was to go any higher

Thanks , I just want to know the stack limit if it is documented, even 25 seem to be heavy for the first module.


yea i belive it is from the master branch. at the bottom of github page in the readme section under “how to use code” i click on releases link then download the source for version Release-2021-01-25-14-42

ive tried the reset fuse option in platformIO but not sure if i tried reflashing afterwards.

ill give that a shot and report back