Community
OpenEnergyMonitor

Community

Demand shaper with two evse chargers ? I messed up

Hi i have just started to look into using the demand shaper as i should be on the octopus tarif soon . at present i have two chargers one is the standard set up as " openevse " and the other
i have named "openevse_1 " I have done this in my mind so that i do not get them confused and also to keep the system from getting confused . only problem is that when i try to set up to use the demand shaper it only will see the first one this is working . but i need to to also let me set up and shedual for the second one . that it does not see .
i used the set up wizard but edit the name by adding the ‚Äú_1‚ÄĚ
How shoudl i have set them up ? nameing etc or how do i get demand shaper to see the second one ? many thanks Bill

1 Like

Hello @Bill_Burgess, did you change the second OpenEVSE to ‚Äėopenevse_1‚Äô on the OpenEVSE MQTT configuration interface? Settings the basetopic here to openevse_1:

image

I believe so as I am logging data to the inputs under the _1
And have feeds generated from these. the feeds I have added the extension _bill. So as to make it clear what I am looking at.

I am well impressed with the demand shaper and have order for some son off switches to try tonight

I will need to see if I can duplicate

The pairing as I have a battery charging rectifier that I control with a aurdino interface to give variable power but want to make so that it will go to full charge level based on the demand shaper . To ensure that

The battery bank has enough charge to cover the high rate period

Regards. Bill

Just checked when home yes as the picture
Regards. Bill

sorted it i did a reinstall of the feeds using the template and this time
it picked it up . i beleave it was because i had changed the feed names as well
but now working …

many thanks for your help

bill

1 Like

Hi Trystan wonder if you can point me in the right direction
I have now set up the demand shaper with both of my evse charge units and these seem to be taking the comands ok . when ajusting settings i get a box apper with an error
emonCMSError Uncaught TypeError Cannot read property to lowercase of undefined
route modules/demandshaper/general.js?v=10
line 481
Column :57
I was wondering if this was because i do not have the SOC moduel fitted and feeding in to the system .

i have been trying to find the source code and binary files to download in to the sonoff switch so i can try this out . in all of the links that i can find in your posts i get a 404 error when i try and follow them . i would prefer to use the aurdino under windows ide . if posable .
or i can download the binary directley using the same programer as i use for the evse board i hope .
ref the demand shaper as i have solar avalable i would like to be able to set up so that during the day the carger defults to solar eco mode when not in the timed charge period
regards Bill

Great to hear that you got it working @Bill_Burgess

Does the ‚ÄúemonCMSError Uncaught TypeError Cannot read property to lowercase of undefined‚ÄĚ go away if you toggle the settings? is it persistant?

Which control option did you select in the ‚ÄúControl based on‚ÄĚ box?

Ah I think this is caused by what was at the time a development branch now having been merged into the master branch with the original deleted. The latest firmware is available here https://github.com/openenergymonitor/EmonESP in the master branch.

I will do a quick search for those broken links.

Hi Thanks for sending this information

I have managed to load the firmware by compiling it with the a Arduino IDE but I think I am missing a part as I have got it running

And when I log on to the ap and link to my network it comes up as espwifi2503 .

When I look at the instructions for compiling in Linux I see you can state what option you want it to configure in ie sonoff smart plug or heat pump etc

By using a different commad line to compile .

I have searched for instruction of what I need to change in the source code I cant seem to find anything about how to do this in the Arduino ide

In the end I took a chance and added this line 66 can you tell me what I should have done please .

also the version number comes up with the variable name not the number I assume I need to add this ? somewhere

// Read saved settings from the config

config_load_settings();

timeClient.setTimeOffset(time_offset);

#define SMARTPLUG // bill added to get it to load correct part

// EmonEsp is designed for use with the following node types:

// Sonoff S20 Smartplug

#ifdef SMARTPLUG

node_type = ‚Äúsmartplug‚ÄĚ;

Thanks for your help

bill

Mail](https://go.microsoft.com/fwlink/?LinkId=550986) for Windows 10

Hello @Bill_Burgess the platform io instructions here are more straightforward on linux, it manages all the dependencies for you, see: https://github.com/openenergymonitor/EmonEsp#option-1-compile-using-platformio

many thanks for this i have just started to use pio to load esp32 wifi for the evse .
glyn helped me get this started but this seems to be a very good write up and will help me

To night i got the esp32 working on both ev chargers but i am now having issue at getting them
to work with the demand shaper every thing is set the same as with the old esp boards .
and i have also tried deleating the inputs and reintilising . i can see both chargers in the demand shaper and i can see the temp and current indication but it reports
openevse_1 Unresponsive top left turns from red to grey … in the inputs i have an input called " Rapi" this is showing as Null and also an input called " in" this is also null .
I am wondering if my sd card version is a bit old as it wont let me update it from the admin page . i have just down loaded emonSD-17oct19.img this seems to be the same as i am running emonpiRelease: emonSD-17Oct19 can you point me to the latest sd image
as i hope that this may help .
I am also intrested in the demand shaper use for my battery charging system i would like to be able to select time periouds based on unit cost above and below ajustable thresh holds
is this something that i could add into the webpage for the sonoff plugs
thanks bill

Hello @Bill_Burgess it sounds like you are running the latest image.

I havent tested the demandshaper with the ESP32 yet, I wonder if there are any rapi changes @glyn.hudson that might affect this?

Do you see inputs from the ESP32 evse’s in emoncms?

Hi yes I am seeing all the inputs just as I was before
After I replaced the WiFi’ modules with the esp32 I set them up to conection with the same topic. And all worked ok. Untill I checked with the demand shaper and found it would not send the commands to the esp32 …
I think tonight I will create a new sd Card and rebuild from scratch On a new card .
As my system has had many changes done to it now I have all my main input devices sorted it may be benifical to start with a clean install to see if that will sort it out .