Dashboards not shown after update

After update and reboot I can’t access my dashboards anymore. I was following this topic but had also no luck.

If I press F12 in the browser and select a dashboard there is no html for the dashboard. See enclosed screen shot

How can I reset this?

All graphs and feeds are visible and no error occures.

There is no /var/www/emoncms/dashboard folder! Could this be the problem?
There is a /var/www/emoncms/Modules/dashboard folder!

I found the following error in apache2 logfile:
[Sat Sep 15 18:38:15.544158 2018] [:error] [pid 3068] [client] PHP Warning: require(Modules/vis/vis_langjs.php): failed to open stream: No such file or directory in /var/www/emoncms/Modules/dashboard/Views/dashboard_edit_view.php on line 22, referer: file: d/Views/dashboard_view.php on line 24, referer:

The file Modules/vis/vis_langjs.php does not exist!

Unfortunately, you don’t give us any information about your system, hardware or emoncms version, or how you installed it.
Without more information its difficult to help.

Go to meny Setup > Administration, and click the ‘Copy to Clipboard’ button in the Server Information section, and paste the results directly into a forum post.


Server Information
Emoncms Version low-write 9.8.28 : 2018.01.27
Modules Administration : App v1.1.1 : Backup v1.1.4 : EmonHub Config v1.0.0 : Dashboard v1.3.0 : Device v1.1.0 : EventProcesses : Feed : Graph v1.2.0 : Input : postprocess : CoreProcess : Schedule : setup : sync : Time : User : Visualisation : WiFi v1.3.0
Buffer loading…
Writer Daemon is running with sleep 60s
Server OS Linux 4.9.35-v7+
Host emonpi emonpi (
Date 2018-09-15 21:42:41 CEST
Uptime 21:42:41 up 3:11, 1 user, load average: 0.17, 0.12, 0.09
HTTP Server Apache/2.4.10 (Raspbian) HTTP/1.1 CGI/1.1 80
MySQL Version 5.5.59-0+deb8u1
Host localhost (
Date 2018-09-15 21:42:41 (UTC 02:00‌​)
Stats Uptime: 11463 Threads: 3 Questions: 2628 Slow queries: 0 Opens: 78 Flush tables: 1 Open tables: 71 Queries per second avg: 0.229
Redis Version 2.8.17
Host localhost:6379 (
Size 55 keys (551.47K)
Uptime 0 days
MQTT Version 1.4.14
Host localhost:1883 (
Pi CPU Temp 45.62°C
Release emonSD-26Oct17
File-system Set root file-system temporarily to read-write, (default read-only)
Memory RAM Used: 29.30% Total: 970.93 MB Used: 284.47 MB Free: 686.46 MB
Disk Mount Stats
/ Used: 62.85% Total: 3.33 GB Used: 2.09 GB Free: 1.08 GB
/boot Used: 36.32% Total: 59.95 MB Used: 21.77 MB Free: 38.17 MB
/home/pi/data Used: 11.57% Total: 968.33 MB Used: 112.02 MB Free: 806.33 MB
PHP Version 5.6.33-0+deb8u1 (Zend Version 2.6.0)
Modules apache2handler : bcmath : bz2 : calendar : Core v5.6.33-0+deb8u1 : ctype : curl : date v5.6.33-0+deb8u1 : dba : dio v0.0.4RC4 : dom v20031129 : ereg : exif v1.4 : fileinfo v1.0.5 : filter v0.11.0 : ftp : gd : gettext : hash v1.0 : iconv : json v1.3.6 : libxml : mbstring : mcrypt : mhash : mosquitto v0.3.0 : mysql v1.0 : mysqli v0.1 : openssl : pcre : PDO v1.0.4dev : pdo_mysql v1.0.2 : Phar v2.0.2 : posix : readline v5.6.33-0+deb8u1 : redis v2.2.7 : Reflection : session : shmop : SimpleXML v0.1 : soap : sockets : SPL v0.2 : standard v5.6.33-0+deb8u1 : sysvmsg : sysvsem : sysvshm : tokenizer v0.1 : wddx : xml : xmlreader v0.1 : xmlwriter v0.1 : Zend OPcache v7.0.6-devFE : zip v1.12.5 : zlib v2.0 :

Client Information
HTTP Browser Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Screen Resolution 1536 x 864
Window Size 1393 x 641

Aaah it’s an emonpi.
Have you tried updating emoncms using the inbuilt script?

Other than that, I’ll leave this for a emonpi user to answer.

Yes, I pressed the emonPi button and emonBase.emonpiupdate.txt (6.6 KB)

…and what was the result, any messages in the log.

see upper post please, I edited it.

It looks as though emoncms is not being updated.

git pull /var/www/emoncms
* stable
On branch stable
Your branch is behind 'origin/stable' by 221 commits, and can be fast-forwarded.
  (use "git pull" to update your local branch)
Changes not staged for commit:
  (use "git add <file>..." to update what will be committed)
  (use "git checkout -- <file>..." to discard changes in working directory)

	modified:   index.php

I suspect that you have made an manual edit to the file index.php at some stage, which is stopping the git update. Could this be the case?

Definetly not. I’m not that familar with git, so I won’t change there anything. Is it possible to repeat this or do you think that the dashboard files are lost?

Oh, I’m sorry. There is a index.php.org in my folder. So there must be some changes, indeed. I’m searching for the reason…

I’ve changes some variables, don’t know why:
$session[‘userid’] = ‘my_name’;
$session[‘write’] = 1;
$session[‘admin’] = 1;
$session[‘editmode’] = TRUE;
$session[‘lang’] = ‘en’;

I try to replace it with the original version

Yes, if you can restore it, and run the update script again, it should update emoncms and hopefully solve your problem.

I used the original one, still the same message. But the one from sourceforge doesn’t run at all.
I tried it with apt-get update / upgrade because git was a newer version availible. It may take a while.

That didn’t work. So I don’t want to spend too much time with this. Is there a way to install the latest release and keep the data and feed/input configuration (which still works) ? I’m afraid to lose the data and settings. To lose the dashboards doesn’t matter, the graphs still work.

I’m not a emonpi user… but I would tackle this by first of all by making a copy of your existing emoncms folder -
cp -r emoncms oldemoncms
so that if it all goes wrong, you can rename oldemoncms back to emoncms, and things will be the same as they are now.

Then from within your emoncms folder, stash any file changes which you may have made. (Try googling ‘git stash’ for details about the ‘stash’ command, or see this guide.)

Then run the update again and see if that fixes the problem. If you then have a fully running system, delete the oldemoncms folder.


Thanks for the tip. I’ll try it next weekend. I have to leave it unsolved.

Hey the same happened to me a few times after updating as it does not automatically install the dashboards module! Make sure you download it and copy to Module folder!!!

1 Like

Big Thanks!:grin:
That did the trick in details:

cd /var/www/emoncms/Modules
mv ./dashboard dashboard.backup (or delete it)
git clone GitHub - emoncms/dashboard: dashboard module for emoncms
git pull