Dashboards - My electric app

I would like to know how can I see the consumption whit Cost in money on My Electric
I ready config as you suggest in documentation

Pic 1


Pic 3

  • If we see the bar on My Electric App , for Sunday Consumption Pic1 , I can see for that day a 6kwh consumption
    if we see the same period in Visualization , for that period I have 2,1 kwh consumption , moving the consumption for sunday to Monday , soo I see on Monday visualization graph the consumption for sunday in My electric

I would like to know if this its a common functionality of the emoncms , or I need some parametrization on it


Please provide more info on your setup:

  • What version Emoncms are your running?
  • Are you running local install or emoncms.org?
  • Are you running on RaspberryPi? Are you running pre-built image?

On a standard Emoncms install just click on ‘cost’ to display cost info in MyElectric:

I’m using the prebuilt card version May 16

in both options I had the same issue

Are you using a comma for decimal separation when entering the unit cost? if so it may be an internationalization quirk, try using a “full stop” decimal point to see if that works.

You haven’t told us anything about the feeds you have based this on, are they derived from the same feed? if so I assume it is a phpfina for the app to work. If that is the case then the graph you have used will be basing the 86400s interval on the time the graph is generated, (if you were to check it again at midnight it would probably align better). Try setting the mode as “daily”.
However if using a specific “Daily” type feed eg “power to kWh/d” which looks like it maybe the case as your pic does not show “delta” set, then I do not believe they are timezone correct and maybe in UTC timezone, so what timezone are you in?

To get the same data in a bargraph as the myelectric app, use the same “use_kwh” feed you use for the my electric app and set delta = 1 and mode = daily, that should be timezone correct as per the myelectric app. You will still see some rounding anomalies though as the rounding in the app is more aggressive.

1 Like

you are correct , I put value = 1 in cost , not like I did before 1,76 , and now is working well

I’m using in visualization
my time zone GMT -3 Buenos Aires