Community
OpenEnergyMonitor

Community

Can't upgrade "/bin/sh: 1: /home/pi/emonpi/update: Permission denied"

I tried updating my old emonpi using the web interface admin page. The update failed. The LCD is stuck showing “temp sensor found” Unit appears to be working otherwise.

Emoncms version: low-write-v8.5
/var/log/emonpiupdate.log has many lines of:
/bin/sh: 1: /home/pi/emonpi/update: Permission denied
I was hoping to upgrade so that I could use newer emonpi features with this old box. I would like to retain my data. Should I leave this alone and get a new emonpi?

That is pretty old and there is no safe way to upgrade, but you should be able to extract the data and load that onto a new system. There have been a number of threads recently about updating from older systems (but this may be the oldest version).

Safest route is to start with a new SD card.

Is the backup facility installed?

If so check that is working is the first step.

Brian, Thank you for your reply. I think I will keep this system as-is for now. It has been running flawlessly since June 2015.

Any idea if there is some way to fix the LCD screen? At power up it shows the AC found, CTs found, and stops at temperature sensor found. I can’t see the IP address and the button does not change the display. The display worked OK until I tried to upgrade using the web interface.

I will buy a new emonpi for the new project that I am working on.

I think it highly likely the SD card is starting to fail.

Taking a backup and putting in a new card is pretty painless generally.