Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Can't reset EmonEVSE wifi AP

I’d like to connect my EmonEVSE to a new WI-Fi network but I can’t get change it via the openenergymonitor site (change wifi network button doesn’t do anything) or via a device reboot.

Anyone know how I can do this please?

take a wifi device, tablet, computer close to the EVSE search for wifi networks and you should see a network something like evse-xxxx connect to this the password should be openevse, open a browser it should bring up the EVSE config page and you should be able to connect to the new wifi

John

Thanks, other devices weren’t picking up the hot spot, I’d connected it to my home wi-if.

I’ve solved it by resetting my router to its factory settings, which can now find the EMon.

I have changed my router SSID so tried to reset the ESVE to connect with the new SSID. Initially I managed to connect a phone in AP mode and change the SSID and password, but then it all went wrong and I couldn’t detect the Wi-Fi signal by any means including directly to the AP. So tried 5 secs on the GP100 button and then 10 seconds on reset button as per GitHub - OpenEVSE/ESP32_WiFi_V4.x: OpenEVSE V3 WiFi gateway using ESP32 9 but my devices won’t detect an OpenEVSE_XXXX AP any more. There are 2 solid green lights shining after all resets and partial resets.

So not sure it’s doing a real reset. Or have it completely wiped the firmware somehow so it does not know its OpenEVSE_XXXX AP anymore? Some docs talk about 10 secs on the GP100 button doing something different from 5 secs on it. Is that true or is it referring to a non EPS32 module?

I don’t have an LCD fitted so can’t see the IP address etc. on it.

The one month old ESVE is charging OK. It’s just the Wi-Fi that has lost its connection.

Not sure of posting protocol here. I am replying to an old similar post rather than create new one.

It is not a ESP32 issue but my new WiFi setup. The ESV32 objects somehow to the TPlink WiFi extender I am using.

Unfortunately there is a bug with the GPIO 0 button at the moment, but I will try and get it resolved as soon as I can.

That being said if it is showing as two green lights I think it should be connected to the WiFi, should flash yellow when connecting and also should revert back to AP mode if it can’t connect. Will also check around this however could be a bug in bringing up the AP mode in general rather than just when the button is pressed.

1 Like