Cannot write meta when create a feed

I’ve installed emoncms on a windows server, but when I try and create my first feeds I’m getting the following errors:

2017-11-05 12:00:31.643|ERROR|PHPFina.php|create_meta() could not write meta data file fopen(C:\emoncmsdata\phpfiwa\ 12.meta): failed to open stream: Invalid argument

2017-11-05 12:00:31.643|WARN|feed_model.php|create() failed to create feed model feedid=12

I’ve tried using a different folder location in case there was a problem with the emoncms folder being directly on the c drive.
Can anyone help me, any info I find online seems to be for linux

I do have emoncms running on Windows; so let’s start comparing…
First thing I’d check is security on the emoncmsdata directory. Next, we should look at the settings.php file. Here’s (2.5 KB)
Are you running under WAMP or IIS?

There is a space in the filename/path - did you mean to include that??

Thanks for the replies, I’m running it under WAMP. My settings file seem to be the same as yours, with the exception of redis. I’ve that set to false.

This is going to sound stupid, but how do I set the security on the directory? I’ve allowed all users full control of that directory, including the user ‘everyone’

Sorry that space was my fault from copying and pasting from the log file.

Security - for a local system, that’s not unreasonable (Mine’s actually Full Control to Users). And that’s on both the C:\emoncmsdata directory and the phpfiwa subdirectory? (You did create the 3 subdirectories - phpfina, phpfiwa, phptimeseries?)
Sounds like we may all need to take a look at your settings & logs - can you zip & post your settings.php & log file (after stopping the WAMP services)? (Scrub anything personal)?
Is there anything in your data directories?

Thanks SandyB,

There’s nothing in the sub directories. I’ve a link below with my logs (I’ve tried different location on the harddrive just in case that made a difference), settings and a snapshot of my permissions.

(I’m only a new user so I cant upload, if the link doesnt work just let me know.


You should be able to now. So please do so. Unlike others, we want you to attach your screenshots, log files, etc to your post. If the external site goes away, the material is likely to be lost forever. If that happens, when someone reads your post, your question and our answer will have little or no value.

Thanks Robert, I’ll upload that now. (39.8 KB)

Can you try this version of settings.php instead? (2.6 KB). I found a line feed character between the last set of back slashed and the closing double quote character in the data file definitions. It didn’t show using notepad, but other editors show it - try Notepad++ (though their web site seems to be down right now). You might actually want to start with the default settings file and remake all your changes using notepad++ - as you say, emoncms is a UNIX “friendly” system, and UNIX text files are different from Windows text files (line-feed separated lines vs. carriage return/line feed separated). Your current settings file has been (mostly) converted to Windows format. Remaking the edits with Notepad++ will keep the file in UNIX format - which PHP may be happier with (and keeps it consistent with everything else).

Sandy your a legend! Thanks a million. That worked perfectly.