Cannot get EmonPi running

Following on from my posting yesterday Problems following new ISP/modem router - #6 by borpin to update the wifi settings on my emonPi. After several hours messing around I had to abandon the installation I had as I think the card is corrupt. So this morning I decided to have a fresh start and downloaded the latest SD build emonSD-17Oct19 . It seems to power up fine and I thought I was finally starting to get somewhere. The two CT’s were were indicating as well as the EmonTH. However when I reboot I am left with the LCD display saying Booting… Please Wait. I can access EmonCMS on it via the wired network however now the inputs all say n/a in red and NULL where they had values before. I have re-written the SD card several times as well as trying alternative cards. Not sure what to try next. Frustrated is an understatement.

On first boot you need to leave the system alone for it to complete a number of updates. Do not reboot during this time.

You can see if it has finished by running htop and seeing what processes are taking all the CPU.

Leave for at least 30mins more preferably.

I am just trying again after another attempt. I had just read something about leaving it to do its own thing. That may be my problem. The last try I have ethernet plugged in and booted up fresh. I got the choice to continue with ethernet or setup wifi. I chose ethernet then created my account. Looking at the log after that I got this!
Starting update via (v3.0) >

So I dont think it had any intention of updating. 17Oct19 is the one I should have isn’t it?

At what point am I supposed to let it do its own thing. Before I even choose to use ethernet and create account or after that?

This is caused by the file not being read correctly from GitHub. Try rerunning the update.

After powerup especially if connected via ethernet.

Run update from the emoncms menu? Or try and SSH in?
I have just flashed another SD card. If I leave it after powerup then I wont know if its had the same error reading from Github. I only see that after creating account and logging in.

Thank’s for your invaluble help and patience.

After leaving it for nearly an hour accepted ethernet and created an account. Checked the update log and had that same error message old or undefined image etc. Now started Full Update which seems to be progressing.

Not touched wifi yet. I am hoping that is not another can of worms as last time I tried I was communicating on wifi despite wifi config giving a disconnected status.

Further update:
I seem to have got it running. It looks like a lot of the problem was not finishing the updates.
Not sure about the wifi. That seems to be working with ethernet removed. But it shows as disconnected still which doesnt make sense.

Connection Info

Status: Disconnected
IP Address:
Mac Address: b8:27:eb:12:3e:8c
Sub Net Mask:
Rx Packets:
Tx Packets:
Rx Bytes: 223898 (218.6 KiB)
Tx Bytes: