Community
OpenEnergyMonitor

Community

Cannot Connect to Ethernet or WIFI

Tags: #<Tag:0x00007fa33b0b9448>

Hello,

I experienced an issue with my wifi network which has now been resolved. My emonpi will not connect to my ethernet or wifi network. Besides reading Ethernet and wifi ‘no connection’ it also reads GSM: NO DEVICE. I tried by connecting an ethernet cable also.

I tried adding wpa-supplicant.conf to /boot, but still no connection.

Please help :pleading_face:

Hi @Neil, what has changed? Has it ever been connected?

For WiFi you may need to SSH into the device and use the Raspbian raspi-config utility to set the locale correctly.

Is this on the LCD?

Hello @borpin, sorry for the delay (I had to perform some real work) and thanks for your help.

Yes, since day one.

The problem started when I noticed the broadband connection (which I monitor) was about half normal speed. I had previously noticed that when connected to my 5 gHz network, the download speed is usually around 50 gbps, when connected to the 2.4 gHz network it’s usually around 25-30 gbps.

I have no idea why the broadband speed should change but this is a different subject and doesn’t matter for our discussion.

My emonpi wifi connection lost it’s connection to the 2.4 mHz and did not connect to the 5 gHz. when I tried to switch to the 5 gHz network in emoncms wifi config.

I tried re-booting to no avail. I tried to add wpa-supplicant.conf to the /boot directory, this had no effect. In the end I connected a keyboard and monitor and checked the /etc/wpa_supplicant/wpa-supplicant.conf file. I didn’t change the file, rebooted and it worked. So basically I have no idea how it ‘got fixed’, and less about how it ‘got broke’. :blush:

SSH was/is enabled and all messages received were on the LCD.

However, in emoncms, wifi config, I see my 2.4 and 5 gHz networks, but when I select the 5 gHz network it will not connect.

I find the Wifi Config ‘options’ confusing for such a simple task as connecting to a network. For example, I can check both networks. Is that right? I thought the selection meant connect to the ‘selected’ network. I don’t mean to criticize, It’s more a case of my novice ‘experience’ level with emonpi/emoncms.

Reboot router?

50 Gigabits per second?
Holy cow, I wish I had network speeds like that! :wink:

So do I, I think I must be getting my Gigahertz’s and Megabits mixed up!

Suffice to say my broadband speeds should all read Mbps. Thanks :smile:

I’m still unable to make emoncms connect to my 5Ghz network from the wifi config screen in emoncms. Can I just manually edit wpa-supplicant.conf to resolve the problem? Or will that create some kind of conflict with emoncms?

I am connected to wifi at 2.4mHz so it’s not an urgent issue.

Best wishes

No guarantee it’ll help, but have you had a look at this?

@Bill.Thomson and @borpin,

Good morning,

Just wanted to let you know that I definitely had a problem with my network. I use an Airport Express to extend my wireless network. This device lost it’s configuration somehow and when I re-configured to extend it created a new 2.4 gHz network with a different name and didn’t extend the 5 gHz network. I also had possible interference from other networks so changed to unused channels.

I’m still not convinced there is not an issue with using emoncms Wifi Config. Every time I tried to connect, the system failed and would not connect again until I re-configure wpa_supplicant.conf. This required adding a keyboard, dismantling the emonpi and connecting an hdmi cable.

I’ll try to look at this again (when I’m in the mood for “dismantllation” again :wink:) to prove one way or another.

Thanks to both of you for helping and providing food-for-thought to help me resolve the issue.

Best wishes, Neil

1 Like

Good to hear you got ‘er goin’ again. thumbsup