Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Cannot connect emonPi to wifi - frozen setup page

Have you got Chrome installed? Could you test and show my the console output from Chrome? Sorry, I’m not familiar with the Safari console output. I’m not convinced there errors we are seeing in the safari console are relevant.

Hi Glyn. Here’s the output from console in Chrome. The error seems to be related to the first network showing up in the scan (see screenshot in next post).

Thanks, that gives us some more info. It looks like maybe the Emoncms wifi module does not like the apostrophe in your SSID. I have tested connecting to a SSID with a space in the name, bit I have not tested with multiple spaces and an apostrophe. Do you have a wifi hotspot with a simple SSID you can test with? You could create a wifi hotspot from a smartphone to test.

Ok, thanks! Unfortunately, that one is a neighbour’s network, which I can’t change. It’s surprising that the signal is stronger than my network. I will try to physically move away further or test it out in a completely different place where I can have access with an ethernet cable.

I’m having the same problem, My set up is Emontx,Emonbase,EmonGLCD. Running EmonSD=3May16,EmonCMS=9.7.1,Emontx3_4=Rev 2.3. I’ve tried several installs of EmonSD on Pi w/no success. Here is my console output:

Ah dear, sorry to hear. Thanks for helping to debug.

Can you connect via ssh? If so it would be very useful to see the contents of etc/wpa_supplicant/wpa_supplicant.conf

$ sudo cat etc/wpa_supplicant/wpa_supplicant.conf

See troubleshooting section of the user guide for information on how to ssh. If your using Windows you will need to use putty. Username is ‘pi’ and pass ‘emonpi2016’

Checked and found “no such file/directory”

That path should have been

sudo cat /etc/wpa_supplicant/wpa_supplicant.conf

Syntax gets you everytime. Here is the print screen, thanks for the correction.

Hi, I also did what you suggested Manuel. Below the output from the terminal.

I can make the wifi work by writing the network SSID and password into the wpa_supplicant.conf file as suggested here: Raspberry Pi Documentation - Configuration

When I physically moved the emonPi, so that the network SSID with the apostrophe wasn’t the first network, it still did not work.

However, setting up the emonPi in a different place with no ‘apostrophe’-networks, it worked out well :slight_smile:

Hi Paul,Glyn and Marc

I replicated what Marc suggested and now I can have wifi access. Why was I not able to before? I thought that the EmonCMS/EmonSD image made it possible.

Thanks Marc

Is this setting up the manual way? By editing the file manually?

Mm interesting, is looks like if any of the SSID’s have special characters in them this causes the emoncms wifi module to not function correctly. I am away for next the week. I will try and debug when I get home. I’m glad you have managed to set up the wifi the manual way.

Hi, I have the same problem, just installed the latest SD image emonSD-07Nov16 on a Pi2 with Edimax
.
My chrome dev console output after hitting “save & connect”:

wifi:129 Uncaught TypeError: Cannot read property 'checked' of undefined
at HTMLButtonElement.<anonymous> (http://10.10.4.115/emoncms/wifi:129:57)
at HTMLButtonElement.dispatch (http://10.10.4.115/emoncms/Lib/jquery-1.11.3.min.js:4:8549)
at HTMLButtonElement.r.handle (http://10.10.4.115/emoncms/Lib/jquery-1.11.3.min.js:4:5252)

There are wifis with “!”, “_”, “-” and “” in my scan list, the first two are very common in standard SSIDs in germany.

my wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

my /etc/network/interfaces:

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface wlan0 inet dhcp

# GSM 3G Hi_Link USB modem
allow-hotplug eth1
iface eth1 inet dhcp

If i follow Marcels steps setting wifi up edditing the wpa_supplicant manually it works.

Since your last answer was from July and this is not fixed in the November image may I suggest giving this more priority? The only wired character i see in my list is “”, but especially in cities where you might have 20+ wifis in range there will be some odd ones.

BR
Johannes

Oh dear, very sorry to hear. Thanks for providing debug info. I will try and take a look as this very soon. Is this the same issue as reported on this thread?

I have a very similar issue to this but this time it’s with a PSK that has a special character in it, it looks like the wpa_passphrase program doesn’t handle that very well.

Also, how do I get the emonPi to see / join a WiFi network on channel 13?

A post was split to a new topic: Using emonPi / emonPi WiFi on Channel 13

I’ve just replied on a new topic :+1:

1 Like