Can’t get the batteries to appear in the browser


No se que problema tengo, no consigo que las baterias aparezcan en el navegador , alguien podia echarme una mano, gracias
I don’t know what problem I have, I can’t get the batteries to appear in the browser, someone could give me a hand, thanks
I’m sorry, my english is bad

Can you describe the problem?

¿Puede describir el problema?

he puesto un Video

I have put a video
check problem

Can I have the link?

"Video unavailable
This video is private."

sorry , try again

Ok, this looks like module number 2 isn’t working - the green LED should be on both modules.

Can you connect just 1 module and see if that appears in the web page ?

I have tried with a single bms and the results are the same, I send you another video of another test with two elements

How did you program the modules? The green led shouldn’t be on like that.

Try programming them again following the instructions on GitHub and using avrdude.

I have followed the instructions again and this is the result

Ok, that looks like the controller board is not receiving data. Check for short circuits or missing solder.

Also check the cable is wired up correctly.

The controller is having difficulty communicating with the cell monitoring modules.
have tried 7 different boards and all with the same result, I start to think that the esp86 is damaged

You can check the ESP on its own - disconnect from the controller PCB and using a wire, connect pins 15 and 14 (D8 + D7) together. This should give you successful communications, but you will see “ignored” errors - that’s good and means the ESP is working.

Reconnect the ESP to the PCB board, but disconnect the modules from the controller. Link the TX and RX with a cable on the controller only.

This should give you successful communications, but you will see “ignored” errors - that’s good.

If this doesn’t work, the controller PCB has a fault - likely soldering issue.

If both work, come back to me!