Brand new emonPi not working

Hi there.

I just received a brand new emonPi today but it does not seem to be working as expected.
WiFi cannot connect and and fails with error “Error: Cannot find /home/pi/emonpi/wifiap/”
I had to create the connection via PuTY.
I cannot create new feed “ERROR: Feed could not be created, could not write meta data file fopen(/home/pi/data/phpfina/2.meta): failed to open stream: No such file or directory”
The data folder does not exist in /home/pi.
I have been unable to update the system either. Fails with /bin/sh: 1: /home/pi/emonpi/ not found

Am I doing something wrong?
Please help!


No I don’t think so. Did you buy a DC power supply and cable as well?

That path is wrong - looks like a rogue SD Card

Email the shop they’ll be able to sort you out. @TrystanLea

In the meantime, if you want to play over the weekend, you could flash a new image to the SD card. It means unscrewing the plate with the CT connections on it.

If you do this, please wait a good while after booting up the first time to make sure it does all the updates. That is usually done in the shop I think.

Hi Brian,

Thanks for the reply :slightly_smiling_face:

Yes, I did get the AC PSU and the usual 5 Volt usb one too.

I have emailed them, they have just replied asking for some screenshot which I will provide.

I will flash a new image in the morning and see what happens.
I will post the result back here.

Thanks again.


1 Like

I have flashed the SD card and all is now working as expected :slight_smile: :smile:
Thanks Brian @borpin
Not sure if I need to run emonSDexpand, I tried and the command failed but disk space is reported to be as before, 3.92GB total.

Just need to learn how to use the system…
Any step by step nooby guide out there? I mainly wan to monitor power from different feeds accurately as well as all site (pulse count I guess).
I need to feed a TH sensor back to home assistant to control a panel heater.
Happy to create one and post back here if these do not exist.

Thanks again for your support.

Follow the ‘Guide’ at the top of the page :grinning:.

Glad you got it working.

I am presuming you mean an emonTH sensor?

There are several ways. There is an emoncms component in Home Assistant you can use. This is probably the easy way.

I updated this component so be interested to know if the instructions work for a new user.

If that doesn’t work for you I’ll expand on some slightly more complicated ways.

Just check under the ‘Feeds’ page in emonCMS, that the units are shown otherwise you need to add them to the Feed setting.

thanks again, you’re a :star2:
I have been using the guide. They are very good articles but I am still struggling as I have never done anything like for a long time. Probably over ten years.
I am not a technophobe and I have some understanding of programming but I am not technical enough to understand the guide with ease.
I was more thinking of a walk through procedure documents for ‘not too technical people’ like me :laughing:
Also I understand that the applications are too broad to have a one fits all kind of document.

I will try the emoncms component and report back :slight_smile:

1 Like

Did you try the video?

@TrystanLea - feedback on guide…

Very good guide.
I have now added emoncms sensors to HA using the emoncms component guide.
Entities have been added successfully using the guide and I can now control what I need so far.
So this is all good news.
I did struggle a bit but this was caused by my formatting. Tabulation is very important in the HA File editor:

    4: "Workshop Temperature"

will work, but

4: "Workshop Temperature"

will not.

Finding sensor IDs took a bit of guessing as to where to look but I got there in the end.

urgh… what video?
To be honest I remember seeing a video thumb somewhere but I don’t think it was for what I was looking for.
To clarify, the guides are good if you are technically minded and already understand how to use the technologies that underpin the functions and integrations available in emonPi.
the emoncms guide is more new user friendly but it still requires some technical understanding from the end user.
As an example, I have still no idea how to configure MQTT, I have tried to SSH the MQQT server to no avail. It is surely something I am doing wrong. But I am not sure as to what it is yet.

Yes YAML is very picky about indentation.

If posting code use ``` - 3 backticks, on a line before and after to format correctly.

What do you need to configure? If you want HA to connect to the MQTT server on the emonPi (assuming HA is on a different machine) use the HA MQTT configuration and point it to the IP of the emonPi.

If you have specific queries, ask away (new threads please) - happy to help.

Thanks. will do.

Nothing in particular. I am just inquisitive, it is the way I learn :slight_smile:

Thanks again for all your help with this btw.

Will do