Booting only when connected to laptop USB

I have one of the first emonpi out there.
Kickstarter 2015.
Recently it failedd due to sd card corruption plus the new releases require larger card then initial 8gb one.
I burned and rebooted having it powered froma laptop for intial setup.
all good.

However now it want reboot when used with the original power supply.
I tried also alternative tablet and phone chargers with the same result.

As soon as I power the supply through PC it will boot (same card).

Has someone had simialr issues?
Can you suggest an alternative charger?

Hello @Nicola_Reina,

The USB port on the PC is probably capable of proving more power than a phone charger and that’s probably why it boots when connected to the PC USB.

The Raspberry Pi may not boot correctly if the power supply is unable to provide enough power to boot up. You can quickly check if the RPi is getting enough power by observing the red LED on the RPi (it blinks when it detects low power condition.) Another way is to connect the HDMI and monitor the boot sequence. If low power is detected a yellow lightening bolt will be displayed during boot up.

Are you using the same USB cable when connecting to the original power supply and when connecting to the PC USB? USB cables have been known to fail. Try a different USB cable.

If you get a new power supply it should be at least 2.5A rated output. Also note that there will always be some amount of red LED blinking, even when the available power is adequate, but the RPi will still boot up. I’ve yet to see a RPi that doesn’t blink even a little on boot up, but you can disregard ‘minimal blinkage’ (if that’s a word.)

Best wishes

Some USB cables are made with very thin (= cheap) wire that has a high resistance and therefore during the initial switch-on surge, the voltage at the Pi end drops to below the operating threshold of the Pi. Without measuring it or swapping to a known good cable, it is not possible to distinguish this from an inadequate power supply. It’s likely that both causes are contributing to the fault.

Yes. I selectively used same usb, same charger etc.
Tried original charger + orignal cable & alternative cables
alternative chargers + original & alternative cables
Laptop + original cable & alternative cables

Only the last combination works :frowning: