Community
OpenEnergyMonitor

Community

Backup Option not available

Ah Ok I had missed that. There is a line in the update script to force a new link, but I suspect the logic is not quite right to make it run.

Or that this new script does not have the ‘f’ to force it (can’t immediately tell which script is being run on update - it’s a bit of a maze right now).

I also couldn’t work out where the config file was generated from. Rather than it being the module install script (which would be logical) it is in the install script for all modules (above).

Emonpi Issue 107

I do not think -f will work on folders without using -n also.

That line should be

ln -snf $emoncms_symlinked_modules/$module/$module-module $emoncms_dir/Modules/$module

IMO

It has always been a maze, now it’s like a 3D maze as not only do the scripts go here there and everywhere (as before) but there is also the live, redundant and not yet rolled out timeline aspect, plus the stable vs master versions of the emoncms repo’s to boot.

[edit]

On a new install, there is no need to force as there is no symlink to replace. I’m pretty sure the issue is the use of the -f on a folder, it follows the symlink and put’s the new symlink in the folder rather than overwriting the existing symlink.

(see https://unix.stackexchange.com/questions/348536/how-to-force-creation-of-a-symbolic-link)

[edit2] having said that (-n req’d) if the backup/backup folder no longer exists, then the symlink should get replaced with just -fas it cannot result in a nested symlink (can’t put a symlink in a folder that doesn’t exist!). IMO the -nf options should still be used together when re pointing a folder symlink, even if it should “work out” cause the link is dead because if things are done in the wrong order eg the backup module doesn’t pull first time due to local changes etc, the result not as expected.

1 Like

Just wanted to provide some information, I hope not to confuse the issue. I have the Backup menu item but not the Post Process menu item. Running v9.9.9

Server Information
Services
emonhub Active Running
emoncms_mqtt Active Running
feedwriter Active Running - sleep 60s
service-runner Active Running
emonPiLCD Active Running
redis-server Active Running
mosquitto Active Running
Emoncms Version low-write 9.9.9
Modules Administration : App v1.2.1 : Backup v1.1.6 : EmonHub Config v1.1.0 : Dashboard v1.3.3 : Device v2.0.0 : EventProcesses : Feed : Graph v1.2.3 : Input : Postprocess v2.0.0 : CoreProcess : remoteaccess : Schedule : Network Setup v1.0.0 : sync : Time : User : Visualisation : WiFi v1.3.1
Git URL: https://github.com/emoncms/emoncms.git : Branch: * stable : Describe: 9.9.8-61-g74f8acaf
Server OS Linux 4.14.71-v7+
Host emonpi : emonpi : (192.168.1.11)
Date 2019-05-15 10:05:09 EDT
Uptime 10:05:09 up 1 day, 26 min, 1 user, load average: 0.36, 0.17, 0.11
HTTP Server Apache/2.4.25 (Raspbian) HTTP/1.1 CGI/1.1 80
MySQL Version 5.5.5-10.1.23-MariaDB-9+deb9u1
Host 127.0.0.1 (127.0.0.1)
Date 2019-05-15 10:05:09 (UTC -04:00‌​)
Stats Uptime: 87993 Threads: 3 Questions: 330338 Slow queries: 0 Opens: 50 Flush tables: 1 Open tables: 44 Queries per second avg: 3.754
Redis Version 3.2.6
Host localhost:6379 (127.0.0.1)
Size
Uptime 1 days
MQTT Server Version Mosquitto 1.4.10
Host localhost:1883 (127.0.0.1)
Pi Model Raspberry Pi 3 Model B+ Rev 1.3 - 1 GB (Sony UK)
SoC Broadcom BCM2835
Serial num. 5ABE4EF9
Temperature CPU: 47.77°C - GPU: 47.8’C
Release emonSD-30Oct18
Memory RAM Used: 24.89% Total: 976.74 MB Used: 243.08 MB Free: 733.66 MB
Swap Used: 0.00% Total: 100 MB Used: 0 B Free: 100 MB
Disk Mount Stats
/ Used: 41.92% Total: 3.81 GB Used: 1.6 GB Free: 2.04 GB
/var/log Used: 4.00% Total: 50 MB Used: 2 MB Free: 48 MB
/boot Used: 51.69% Total: 42.52 MB Used: 21.98 MB Free: 20.54 MB
/home/pi/data Used: 1.53% Total: 10.32 GB Used: 161.22 MB Free: 9.63 GB
/mnt/usbdrive Used: 0.24% Total: 28.97 GB Used: 70.34 MB Free: 27.4 GB
PHP Version 7.0.30-0+deb9u1 (Zend Version 3.0.0)
Modules apache2handler : calendar v7.0.30-0+deb9u1 : Core v7.0.30-0+deb9u1 : ctype v7.0.30-0+deb9u1 : curl v7.0.30-0+deb9u1 : date v7.0.30-0+deb9u1 : dom v20031129 : exif v7.0.30-0+deb9u1 : fileinfo v1.0.5 : filter v7.0.30-0+deb9u1 : ftp v7.0.30-0+deb9u1 : gd v7.0.30-0+deb9u1 : gettext v7.0.30-0+deb9u1 : hash v1.0 : iconv v7.0.30-0+deb9u1 : igbinary v2.0.1 : json v1.4.0 : libxml v7.0.30-0+deb9u1 : mbstring v7.0.30-0+deb9u1 : mcrypt v7.0.30-0+deb9u1 : mosquitto v0.4.0 : mysqli v7.0.30-0+deb9u1 : mysqlnd vmysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $ : openssl v7.0.30-0+deb9u1 : pcre v7.0.30-0+deb9u1 : PDO v7.0.30-0+deb9u1 : pdo_mysql v7.0.30-0+deb9u1 : Phar v2.0.2 : posix v7.0.30-0+deb9u1 : readline v7.0.30-0+deb9u1 : redis v4.1.1 : Reflection v7.0.30-0+deb9u1 : session v7.0.30-0+deb9u1 : shmop v7.0.30-0+deb9u1 : SimpleXML v7.0.30-0+deb9u1 : sockets v7.0.30-0+deb9u1 : SPL v7.0.30-0+deb9u1 : standard v7.0.30-0+deb9u1 : sysvmsg v7.0.30-0+deb9u1 : sysvsem v7.0.30-0+deb9u1 : sysvshm v7.0.30-0+deb9u1 : tokenizer v7.0.30-0+deb9u1 : wddx v7.0.30-0+deb9u1 : xml v7.0.30-0+deb9u1 : xmlreader v7.0.30-0+deb9u1 : xmlwriter v7.0.30-0+deb9u1 : xsl v7.0.30-0+deb9u1 : Zend OPcache v7.0.30-0+deb9u1 : zlib v7.0.30-0+deb9u1
Client Information
HTTP Browser Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.1 Safari/605.1.15
Screen Resolution 1680 x 1050
Window Size 1480 x 870

I finally was able to spend time to fix this problem, and it works… thank you for your dummy instructions… BUT in the first line,

[email protected]:/var/log $ cat  /home/pi/backup/config.cfg

the $ should be #. I fixed it and it worked great!
The config.cfg file was no-where to be found, and I don’t know WHERE
it went, but I used nano to create a new config.cfg file, copied and pasted the code in your response, fixed the $ #, and tested it out… worked great and I now have a sidebar import/export menu when I select backup under SETUP.
Thanks again!