Assistance with INPUTS

Hi Everyone,

I am using on my web browser via Windows PC.
Raspberry Pi writing data with API key.

I have the following 2x Processes running

1 Log to Feed Power_from_House
2. Power to kWh House_kWh_Consumption

I would like to add a multiplier to House_kWh_Consumption to calculate the cost of consumption.

I have tried add multiplier as process 3, but the multiplier uses the Feed from process 1.

Any suggestions how to set this up correctly?

Thank you.

Anyone care to please assist?

Thank you

I don’t normally use Maybe something like this will work:

Hi Jon,

Thank you for taking the time to respond.

I seem to get an feed error when I try this. Would this mean the is not compatible with this feature?


How odd! It should have worked!

I grabbed an unused input and tried something similar. Give this one a try:

This one is on

Hi Jon,

No luck. but thanks for the help.

Maybe somebody else can comment on the error.


did you get the same error again?

That’s correct and that’s what you need. Process 3 needs to be an adjustment for “price per unit” and that will arrive at the “current hourly running cost” which you can save if you choose but to get an accumulating “total spend” you should use another “power to kWh” process.

Think of the “power to kWh” process as a “flow rate to running total” process with in-built x0.001 scaling (the scaling you will need to counter in your unit price adjustment0.

eg a 100w load at unit price of 15p per kWh after 30mins would look like this

process value name/desc
log to feed 100 current power
power to kwh 0.05 energy used
x 15 kwh unit price
power to kWh 0.75 total spent

or if you want to see/save the current running cost

process value name/desc
log to feed 100 current power
power to kwh 0.05 energy used
x 0.015 kwh unit price / 1000
log to feed 1.5 current running cost per hour
x 1000 to counter the kilo conversion
power to kWh 0.75 total spent

I can see that the +feed process on is resulting in the error as you describe @FlipSnyman. I will see if I can fix it and update soon

Hi Paul & Trystan,

Thank you very much for the effort and great assistance, it is much

One last question, please?

Why does the Bargraph Zoom functions (D,W,M,Y) sometimes not work? Usually
also when I hover over the bargraph the value was displayed.
Any setup I’m perhaps not doing correct?

Best regards