Android App negative 'bars'

Since a short time (I noticed it yesterday) the app is not showing any negative ‘bars’ any more. It certainly worked before. I have negative values when my PV production is bigger than my consumption. The graph is still showing negative values but the blue bars are only positive and are just ‘blank’ when the value is negative.
(this is the opposite behavior compared to the EmonCms ‘My electric’ app where the graph is not showing negative values but the bars go a little bit below zero without showing a value. A little bit inconsistent.)

BR, Jörg,

nobody has answered to my question.
Is this just because nobody has the same problem, or is it the ‘normal’ and ‘wanted’ behavior of the App?

BR, Jörg.

Hi Jorg,

I believe the My Electric app and the Android App are not designed to show negative bars, is this correct @JumpMaster @TrystanLea ?

Have you tried using the SolarPV app to show solar PV use vs consumption. See the solarPV app setup guide:

Hi Glyn,
thank you for the reply. The bad thing (for me) is that it has ‘worked’ before. So there must have been a change and I am not sure if it was a change in the right direction :slight_smile:
And I just wanted to mention the slight inconsistency (although it is correct that whereas ‘power’ can be positive and negative, ‘Use today’ tends to indicate a purely positive value).
Otherwise I am still very happy with the App!!!

BR, Jörg.

PS: SolarPV app: I only have one energy meter and so my whole ‘house’ either ‘consumes’ or ‘produces’ energy. So the SolarPV is not really helpful for me (I think)

I’ve pushed version 1.3.0 which should restore this functionality. Although as Glyn said it hasn’t been designed with that in mind.

Ok, understood. Thank you very much for the change back. I think it is not a disadvantage for anyone, because you simply get the same results if your energy flow is always positive. But it certainly helps for people like me who also have ‘negative energy flow’. Having days with a ‘blank’ energy use in the display is a bit strange :-).
BR, Jörg.

EDIT: have just updated to 1.3.0, perfect!!! Thank you!