Add a SPI thermocouple?

I would like to add a thermocouple by using MAX31855. It run on the SPI BUS but i cannot obtain a good result.
I connect it on the ISP connector (GND, VCC, MISO, CLK) and for the slave select (CS), i used the D3 of the arduino. I do not use the DS18B20 sensor at this time.
I compiled the arduino code by adding max31855 library and erase the code lines about DS18B20.

But, it does not work. By monitoring the serial output or the arduino, the thermocouple give 0 / no connection. The problem seems to be hardware because I test it with a simple arduino and it is ok.
I also tried to add a pull-up resistor for the CS output but the result is similar.
Is it possible to have a hardware problem with the rest of the component ?
Any idea to check ?

to what?

to an emonpi V1.6 and a emonSD-24Jul20

The emonPi uses INT1 (D3) for pulse counting, so it is normally set as an input pin with the internal pull-up enabled.

Also remember that the SPI bus is used by the radio, and that is interrupt-driven - when a radio message arrives, it has to be handled immediately, character by character, and any attempt to use the SPI for something else will result in failure. So, as you are likely to be using the discrete-sample software in your Atmel ATMega 328P front end of the emonPi, you probably need to disable the RFM69CW.

The new CM software for the emonPi front end polls the RFM69CW module, so if you change to that, you should be able to share the SPI bus between the radio and the thermocouple (because the radio will hold the incoming message in its buffer until polled by the main loop of the sketch).

Or, have you looked at using the 1-wire bus?

If I’m right, you can use that and the thermocouple will appear as another temperature sensor - but it appears that you might need to make some changes to the code.

What is the Arduino you mention? Are you saying, you have connected your thermocouple to an Arduino, written a sketch using the Max31855 library and that works?

Thanks for all elements:

By disabling the RFM69CW (“bool RF_STATUS=false;”) it works ! Thanks.

I do not try a 1-wire bus solution because I have also MAX31855 modules MAXIM with all thermocouple connectors. So I prefer this solution for use in my lab.

I use a basic arduino UNO with differents Max31855 library : RobTillaart, Zanduino and Adafruit one.