Community
OpenEnergyMonitor

OpenEnergyMonitor Community

433MHz emonTx inactive but WiFi not

Tags: #<Tag:0x00007f1d4c411e58>

I have 3 x emonTx using 433MHz radio and 1 emonTx using WiFi to connect to the emonbase I have.
Originally I had the 3 x emonTx using radio to connect, and they often dropped off as inactive, but a reboot of the emonbase usually sorted it.
Then I added another emonTx and connected it to the same emonbase over the WiFi. Initially all four emonTx were passing data to the emonbase, but then the 433MHz ones all went inactive, and no matter what I do, nothing gets them talking back to the emonbase. I have upgraded the emonCMS/emonbase/Pi to all the latest software updates, but again, to no avail.
Has anyone got any ideas?
There’s nothing in the logs. And by nothing, I mean they are empty, not there there is nothing relevant.

Did you disable/switch off the RFM on the WiFi TX (I assume this is the emonESP module)?

It could be you are getting RFM clashes.

Have you tried powering down the EmonBase - totally remove power then power up. My old RFM card seems to get stuck and the only remedy is a complete power down.

Then try resetting each TX in turn with a 2 second gap.

Brian,
Thanks, the total power off seemed to do the trick. Whereas I was rebooting the Pi and powering off the emonTx.
Yes, the RFM on the WiFi Tx is turned off.
So it seems that the long-term solution for reliable data is to switch from 433 to WiFi?
Not sure if I should research this first, but on my emonTx where I have a 9V supply (Vrms is reported as 251V), I get negative numbers. But I also have a USB power lead plugged in. I didn’t see in any instructions that if I have a 9V supply plugged in I don’t need a 5V USB, so I assumed I needed both. Any observations?

For a standard emonTx, you only need one or the other - the a.c. adapter is usually the one to have because that measures the voltage and enables real power calculations. If the distortion created by drawing power from the adapter is a worry, you can have the 5 V USB power too. If your mains voltage is consistently low or you power many temperature sensors or especially the Wi-Fi adapter, you need the 5 V USB power supply. If you don’t have the a.c. adapter, you can’t measure real power at all, what comes out is apparent power based on a nominal (i.e. a guessed value) voltage - so not very accurate.

That doesn’t in fact reboot the “emon” part, only the Pi itself. Hence it didn’t reset the radio.

I’ve said before that happens and some doubt was cast on my assertion - glad it fixed it for you :grinning:

It does as every service gets started afresh. If the OS is stopped, what ‘emon’ part is still running on the Pi?

Only way to properly do this is to remove the power from the Pi.

I define an emonBase as a Pi with an RFM69Pi piggy-backed on it. The RFM module itself and ATMega that make up the RFM69Pi aren’t, as far as I’ve been able to trace, restarted except by a power-down. Although the RFM has a reset input pin, I don’t believe it’s used at all.

If it’s a pure Raspberry Pi, then a reboot will start everything.

That is my experience.

Got it!
Thanks guys