Community
OpenEnergyMonitor

OpenEnergyMonitor Community

3phase 3 power lines inputs + neutral are not added for kWh calc

Tags: #<Tag:0x00007fc9aff39320> #<Tag:0x00007fc9aff390a0> #<Tag:0x00007fc9aff38bc8>

Greetings from Austria!

I’m using 2 emontx with 3phase firmware, 1 emonpi and a local emoncms installation on docker + ubuntu (I got it working)
my goal is to monitor the consumption of the house (overall) and to find during the day when do I have which consumption to evaluate a PV
On the emoncms I can see the live input values of the emontx which has his sensors (P1,P2,P3,N) at the main lines. on the input side at the emonpi I have for lines P1-P3 the processes:
P1: >0, Log to Feed P1
P2: >0, Log to feed P2
P3: >0, Log to feed P3

Power1: Log to Feed P1
+Input P2
+ Input P3
Log to feed new feed: Use
Power to kWh new feed: Use_kwH

At first I saw on the emonpi in the feed Use and kWh values but then it was like only once …nothing was added.
Then I tried the same on the emoncms level - but there it never worked (I initialized the input with HomeEnergy Monitor of the emonpi, and when it didn’t work then with the same of emontx - both have the value Null in the feeds. The only hardware change I did was to plug the emonpi with the usb on an USV and the 9volt plug is on the normal ac. I tried now several times erasing the inputs and try new but with the same result - live input works but adding calculation doesn’t - what mistake do I make? Thank you very much for your help!!! BR Gerald. … To add something: I used one emontx plus the emonpi with emoncms on docker in a Synology for 2-3 years now. Now I deleted everything, made an upgrade of all components to the latest version (3phase emontx and emonpi with sd card). I deleted now all inputs and data and try to make it new - still the same result - it seems as the +input doesn’t work… BR Gerald.

Answering myself if somebody experiences the same issue: - it works now - what did I change:
I did a complete reset of the emonpi (via terminal) to get rid of the old data.- this leaded to strange behaviors and multiple services not starting because of right issues (and log files which were deleted by the reset). The old feeds and input config were still here. With the help of old posts I was able that emonpi allowed an update - with that update he restored the pieces which were missing. Then in the input device configuration of emonpi I didn’t change to Home Energy monitor - instead I stayed at the standard inputs of the 3phase firmware of emontx (only to change the names of the devices). Now emonpi get the data of emontx - emonpi passes the data to the docker container with emoncms. there I configured the input policies for the 3 phases:
1: >0, log to P1
2:>0, log to P2
3:>0, log to P3, +Inp 1, +Inp 2, log to use, kWhaccumulator log to use_kwh

At the end I think it was not the reset but the device configuration - before I took the Home Energy monitor to get an additional input - maybe this has issues with 3phase ctx?

BR Gerald

There was an error on the policy now - after log to use,
–> I multiply by 0.001 now
then the kWhaccumulator

Is this the correct usage or should I stay with the previous Power to kWh process? I would like to have a day per day kWh report and to see during the day when do we consume what.

BR Gerald